User Tools

Site Tools


zigbee_plugin_-_using_plugin_interface_module

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
zigbee_plugin_-_using_plugin_interface_module [2016/05/16 20:28]
Joseph Morrow
zigbee_plugin_-_using_plugin_interface_module [2016/05/16 20:29] (current)
Joseph Morrow
Line 1: Line 1:
-====== To run unit tests, please do the following: ======+====== ZigBee Plugin - Using Plugin Interface module. ====== 
 + 
 +===== To run unit tests, please do the following: ===== 
 + 
  
     1. At root of repository/​project directory issue command: "scons TEST=1"​     1. At root of repository/​project directory issue command: "scons TEST=1"​
  
-====== To set up your environment and run the sample applications please follow below instructions:​ ======+===== To set up your environment and run the sample applications please follow below instructions:​ ===== 
 First and foremost you will need a Telegesis USB Dongle. The model I used during development was a Telegesis USB Dongle “ETRX357USB-LR”. The firmware on this dongle will need to be upgraded. This firmware will need to be obtained through contacting the sales team at Telegesis’ website (we used this link to find a sales representative for our devices: http://​www.silabs.com/​buysample/​pages/​contact-sales.aspx?​view=map). You will need to ask for a firmware upgrade to version 3.10 (known as R310). The stock firmware version will not work as it only supports a subset of the required full functionality used in our plugin architecture. First and foremost you will need a Telegesis USB Dongle. The model I used during development was a Telegesis USB Dongle “ETRX357USB-LR”. The firmware on this dongle will need to be upgraded. This firmware will need to be obtained through contacting the sales team at Telegesis’ website (we used this link to find a sales representative for our devices: http://​www.silabs.com/​buysample/​pages/​contact-sales.aspx?​view=map). You will need to ask for a firmware upgrade to version 3.10 (known as R310). The stock firmware version will not work as it only supports a subset of the required full functionality used in our plugin architecture.
  
zigbee_plugin_-_using_plugin_interface_module.txt · Last modified: 2016/05/16 20:29 by Joseph Morrow